Loading...

LR-LoadRunner@googlegroups.com

[Prev] Thread [Next]  |  [Prev] Date [Next]

Re: Logout Successful - Howevwer users still hanged - Weird hu? Kamran Khan Sun Feb 12 22:00:11 2012

Hi Prasenjit/Isaí Azael,

There were two reasons for that. Just to confirm, you are talking about web
server sessions or database sessions?
For Web: It was due to timeout from database, which causes connections on
web to remain open and keep waiting for API to respond. It keep on waiting
till timeout occurs.
For DB: It was due to few reasons (locking, long query, full table scan),
session throw exception and unable to close session appropriately.
So the problem was leaving connection aliv (un-terminated) and not that for
every VUser there were 2 connections were being created.

Hi Raj,

The problem was more likely a performance problem so this will not be
reproduced manually - unless application is under load.


Sincerely,
Kamran Khan
Principal/Lead, SQA & Test Automation
BSCS Hons., MBA, Certified HP PC <http://chromeinstitute.com/>, LR,
QTP<http://chrometechnologies.org/>&
CCNA <http://chromehosting.net/>
 <http://pk.linkedin.com/in/khankamran>


On Sun, Feb 12, 2012 at 11:15 PM, raj <[EMAIL PROTECTED]> wrote:

> Hi All,
>
> If the script is doing what it is supposed to - in this case logout -
> the issue can be with the application itself. One way of validating
> this is
>
> Have SAP basis support
> Do a one user manual test - not using LoadRunner script - perform the
> exact same steps script is performing
> Finally logout
> Ask basis support to validate the user session
> If it is in application issue, one user manual test should show the
> same problem what you see from the script
>
> thanks
> Raj
> https://performancetestingfun.googlepages.com
>
>
> On Feb 10, 3:29 am, Prasenjit Dutta <[EMAIL PROTECTED]> wrote:
> > Hi Kamran/Isaí Azael Villarreal,
> >
> > I am also facing the same issue, we are testing SAP SRM application,
> while
> > running the script with a single users it is creating multiple session
> and
> > keep on consuming the memory. Once logout the session and user keept
> > logging and takes huge time around 10-15 mins to be removed from the
> > system. I really think that, this is a application side problem. Kamran
> > could you provide us the input on how and where the problem ws fixed.
> >
> > Thanks,
> > Prasenjit
> >
> >
> >
> >
> >
> >
> >
> >
> >
> > On Fri, Feb 10, 2012 at 1:22 PM, Kamran Khan <[EMAIL PROTECTED]>
> wrote:
> > > I faced similar issue when testing a Flex.J2EE platform application
> but at
> > > the end of the day, the problem was found and fixed in the application.
> >
> > > Sincerely,
> > > Kamran Khan
> > > Principal/Lead, SQA & Test Automation
> > > BSCS Hons., MBA, Certified HP PC <http://chromeinstitute.com/>, LR,
> QTP<http://chrometechnologies.org/>&
> > > CCNA <http://chromehosting.net/>
> > > <http://pk.linkedin.com/in/khankamran>
> >
> > > On Fri, Feb 10, 2012 at 7:57 AM, Isaí Azael Villarreal <
> > > [EMAIL PROTECTED]> wrote:
> >
> > >> Hello , i´m facing a very uncommon problem. I have never fece it
> > >> before.
> >
> > >> We are testing a SAP webdynpro protocol website.
> > >> We manage to record and edit scripting in order to make everithing
> > >> work ok, but the problem is...
> >
> > >> When logging out... SAP basis team still seeing stress user sessions
> > >> Up.
> > >> Even a trace was turned on, and actually every Vuser make a duplicity
> > >> for the conections. (10 Vu running , surprisingy are generating 20
> > >> connections) when the 10 Vu scenario finishes...
> > >> the 20 connections still hanged and we need to wait for timeout.
> >
> > >> I have review the script code million times ,.. and sap logout
> > >> instruction is excecuted from LR (sap.portal.dsm.Terminator) with no
> > >> problem. also additional instruction LogOutComponent.
> > >> I have tried now LR 9.5 and NeoLoad tools.
> > >> Both of them the same problem, which is weird.
> >
> > >> Sombody told me it could be an Explorer issue "nomerge" config in
> > >> order to set each IE session as indivudual or so.
> > >> but i have not tried this option yet.
> >
> > >> In the meantime... can anybody throw some light?
> >
> > >> Thanks in advance , i Really appreciate all the advice.
> >
> > >> --
> > >> You received this message because you are subscribed to the Google
> > >> "LoadRunner" group.
> > >> To post to this group, send email to [EMAIL PROTECTED]
> > >> To unsubscribe from this group, send email to
> > >> [EMAIL PROTECTED]
> > >> For more options, visit this group at
> > >>http://groups.google.com/group/LR-LoadRunner?hl=en
> >
> > > --
> > > You received this message because you are subscribed to the Google
> > > "LoadRunner" group.
> > > To post to this group, send email to [EMAIL PROTECTED]
> > > To unsubscribe from this group, send email to
> > > [EMAIL PROTECTED]
> > > For more options, visit this group at
> > >http://groups.google.com/group/LR-LoadRunner?hl=en
> >
> > --
> > Prasenjit
>
> --
> You received this message because you are subscribed to the Google
> "LoadRunner" group.
> To post to this group, send email to [EMAIL PROTECTED]
> To unsubscribe from this group, send email to
> [EMAIL PROTECTED]
> For more options, visit this group at
> http://groups.google.com/group/LR-LoadRunner?hl=en
>

-- 
You received this message because you are subscribed to the Google "LoadRunner" 
group.
To post to this group, send email to [EMAIL PROTECTED]
To unsubscribe from this group, send email to
[EMAIL PROTECTED]
For more options, visit this group at
http://groups.google.com/group/LR-LoadRunner?hl=en