Loading...

communityengine@googlegroups.com

[Prev] Thread [Next]  |  [Prev] Date [Next]

[CommunityEngine] Re: Rails 2.3 compatibility Bruno Bornsztein Mon Apr 27 21:17:46 2009

Is your environment.rb file updated? You have to require desert before the
Rails initializer block (see step 6 of Readme or UPGRADE.markdown)

On Thu, Apr 23, 2009 at 11:00 PM, eksatx <[EMAIL PROTECTED]> wrote:

>
> Thanks for the response, but while I am using Ubuntu also, I did not
> use synaptic to install rmagick.  I used synaptic to install ruby,
> built and installed gem from source, then installed rails and all
> other gems (including rmagick) with gem.  Again, the stable branch of
> CE is working fine and using rmagick on this machine with rails 2.2.2.
>
> On Apr 23, 10:54 pm, Tom Bostelmann <[EMAIL PROTECTED]> wrote:
> > i had similar problems when i used synaptic package manager (for ubuntu)
> to
> > install rmagic and the mysql gem.  if you're using a package manager to
> > install gems instead of 'gem' itself, this might be part of the problem.
> >
> > On Thu, Apr 23, 2009 at 8:51 PM, eksatx <[EMAIL PROTECTED]> wrote:
> >
> > > I also get an error trying to generate the CE migrations.  It tells me
> > > I am missing the rmagick gem, even though I know it is installed and
> > > working (my existing stable version of CE relies on it).
> >
> > > From the stack trace:
> >
> > > Missing these required gems:
> > >  rmagick
> >
> > > You're running:
> > >  ruby 1.8.7.72 at /usr/bin/ruby1.8
> > >  rubygems 1.3.1 at /home/errol/.gem/ruby/1.8, /usr/lib/ruby/gems/1.8
> >
> > > Run `rake gems:install` to install the missing gems.
> >
> > > However --
> >
> > > gem list
> >
> > > *** LOCAL GEMS ***
> >
> > > actionmailer (2.3.2, 2.2.2)
> > > actionpack (2.3.2, 2.2.2)
> > > activerecord (2.3.2, 2.2.2)
> > > activeresource (2.3.2, 2.2.2)
> > > activesupport (2.3.2, 2.2.2)
> > > aws-s3 (0.6.1)
> > > builder (2.1.2)
> > > desert (0.5.0)
> > > haml (2.0.9)
> > > hpricot (0.8.1)
> > > htmlentities (4.0.0)
> > > mime-types (1.16)
> > > rails (2.3.2, 2.2.2)
> > > rake (0.8.4)
> > > RedCloth (4.1.9)
> > > rmagick (2.9.1)
> > > sqlite3-ruby (1.2.4)
> > > xml-simple (1.0.12)
> >
> > > On Apr 23, 3:16 pm, Antoine <[EMAIL PROTECTED]> wrote:
> > > > Nice !
> >
> > > > I just updated ! It works fine !
> >
> > > > Congrat !
> >
> > > > Antoine
> >
> > > > On Apr 23, 6:31 pm, Bruno Bornsztein <[EMAIL PROTECTED]>
> > > > wrote:
> >
> > > > > Ok, just merged the desert branch into edge (and deleted the desert
> > > branch).
> > > > > So the edge branch now runs on Desert and is Rails 2.3 compatible.
> To
> > > > > install:
> > > > > rails your_app_name -mhttp://
> > >www.communityengine.org/install_template.rb
> >
> > > > > Thanks,
> > > > > Bruno
> >
> > > > > On Wed, Apr 22, 2009 at 11:42 AM, Bruno Bornsztein <
> >
> > > > > [EMAIL PROTECTED]> wrote:
> > > > > > Update: installing CE (the Desert version) is getting even
> easier:
> > > > > > rails your_app_name -m
> >
> > >http://github.com/bborn/communityengine/raw/desert/community_engine_s.
> ..
> >
> > > > > > (If you're willing to try out the Desert version of CE)
> > > > > > This will build a complete Rails app with CE installed in one
> click.
> > > After
> > > > > > it completes, all you have to do is start your server!
> >
> > > > > > Let me know if you try it out and have any feedback.
> > > > > > Thanks,
> > > > > > Bruno
> >
> > > > > > On Sun, Apr 19, 2009 at 8:40 PM, Bruno Bornsztein <
> > > > > > [EMAIL PROTECTED]> wrote:
> >
> > > > > >> Update: I have a CE branch going that uses Desert instead of
> > > Engines:
> > > > > >>http://github.com/bborn/communityengine/tree/desert
> >
> > > > > >> I'll playing with this for a couple of days in my apps to see
> how
> > > well it
> > > > > >> integrates, and wether I want to move in that direction. As
> always,
> > > feedback
> > > > > >> is appreciated.
> >
> > > > > >> Thanks,
> > > > > >> Bruno
> >
> > > > > >> On Fri, Apr 17, 2009 at 8:30 PM, Bruno Bornsztein <
> > > > > >> [EMAIL PROTECTED]> wrote:
> >
> > > > > >>> Update; after doing some more investigating, looks like some of
> the
> > > > > >>> Engines features I really like (namely, code mixing) break in
> 2.3.
> > > For
> > > > > >>> example, even with the latest Engines plugin installed, helpers
> > > aren't being
> > > > > >>> mixed correctly. I'm going to spend a little more time thinking
> > > about how to
> > > > > >>> proceed (and evaluating whether CE should switch to using the
> > > Desert
> > > > > >>> plugin).
> > > > > >>> I'm open to feedback or suggestions; but it's a little hard to
> know
> > > > > >>> exactly where Rails will go (will they support all of Engines
> > > features or
> > > > > >>> not), and where Engines will go (will it be updated to maintain
> > > > > >>> compatibility with 2.3)?
> >
> > > > > >>> For now, I'd advise against upgrading CE apps to 2.3, until we
> get
> > > this
> > > > > >>> figured out.
> >
> > > > > >>> Thanks,
> > > > > >>> Bruno
> >
> > > > > >>> On Thu, Apr 16, 2009 at 7:56 PM, Bruno Bornsztein <
> > > > > >>> [EMAIL PROTECTED]> wrote:
> >
> > > > > >>>> Edge is where the development happens, but I hadn't done any
> 2.3
> > > > > >>>> compatibility stuff there yet. I'm keeping the Rails 2.3 stuff
> in
> > > its own
> > > > > >>>> branch (rails_2.3) to allow people to test it out before
> merging
> > > it into
> > > > > >>>> edge.
> >
> > > > > >>>> On Thu, Apr 16, 2009 at 7:26 PM, Tom Bostelmann <
> > > [EMAIL PROTECTED]>wrote:
> >
> > > > > >>>>> I'm a little confused.  I thought the 'edge' branch was where
> you
> > > were
> > > > > >>>>> working on rails 2.3 changes.  In fact, I'm using the 'edge'
> > > branch with my
> > > > > >>>>> project as we speak - the big caveat being that I'm using
> only a
> > > subset of
> > > > > >>>>> the functionality.
> >
> > > > > >>>>> In any case, sorry for posting my confusion - but is there
> any
> > > > > >>>>> documentation that explains what each branch is for?
> >
> > > > > >>>>> Tom
> >
> > > > > >>>>> On Thu, Apr 16, 2009 at 5:03 PM, Bruno Bornsztein <
> > > > > >>>>> [EMAIL PROTECTED]> wrote:
> >
> > > > > >>>>>> Hey all,Finally had a moment this afternoon to start on
> Rails
> > > 2.3
> > > > > >>>>>> compatibility for CE, and it was easier than I expected:
> >
> > > > > >>>>>>http://github.com/bborn/communityengine/tree/rails_2.3
> >
> > > > > >>>>>> (Note: you'll need the latest Engines plugin)
> >
> > > > > >>>>>> All tests are passing, but I'm not using it on production
> yet,
> > > so I'd
> > > > > >>>>>> appreciate feedback from people. Once I get my apps
> upgraded,
> > > I'll merge
> > > > > >>>>>> this into edge. The next point release of CE will be 2.3
> > > compatible.
> >
> > > > > >>>>>> Thanks,
> > > > > >>>>>> Bruno
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"CommunityEngine" group.
To post to this group, send email to [EMAIL PROTECTED]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/communityengine?hl=en
-~----------~----~----~----~------~----~------~--~---