Loading...

engine-users@lists.rails-engines.org

[Prev] Thread [Next]  |  [Prev] Date [Next]

Re: [Engine-Users] has_many_polymorphs_plugin breaks routes James Adam Tue Oct 09 00:08:04 2007

Hi Sean,

The first step would be to figure out why the routing is failing -
what's the entry in your routes file that *should* match
"/admin/categories/list" ? Do you have a complete sample app
(including your plugins) that demonstrates this failure?

- James

On 9/28/07, Sean Schofield <[EMAIL PROTECTED]> wrote:
> Just started playing with Engines (excellent work btw.)  Anyways
> everything was working fine in my plugin until I added
> has_many_with_polymorphs plugin into the mix.  Then all of a sudden my
> routes are broken.
>
> Everything works fine before adding this plugin and the plugin itself
> works fine in other apps.  I've also tried forcing engines to load
> first but this doesn't change the outcome.
>
> Here are the relevant pieces of my logfile.  If you want to see it in
> action yourself please see our project website (railscart.org) and you
> can grab the sourcecode.  You will just need to add the
> has_many_polymorphs to the starter application.
>
> TIA,
>
> Sean
>
> engines has started.
>    [4;36;1mSQL (0.000000) [0m    [0;1mSET SQL_AUTO_IS_NULL=0 [0m
>    [4;35;1mSQL (0.000000) [0m    [0mSELECT version FROM schema_info [0m
> loading plugin from
> ./script/../config/../vendor/plugins/has_many_polymorphs with engine
> additions
> ** has_many_polymorphs: rails environment detected
> ** has_many_polymorphs: loaded ok
> Plugin 'has_many_polymorphs': starting load.
> Plugin 'has_many_polymorphs': loaded.
> loading routes from ./script/../config/../vendor/plugins/railscart/routes.rb
> ** has_many_polymorphs: autoload hook invoked
> loading routes from ./script/../config/../vendor/plugins/railscart/routes.rb
> checking plugin 'acts_as_paranoid' for 'application_helper'
> checking plugin 'engines' for 'application_helper'
> checking plugin 'has_many_polymorphs' for 'application_helper'
> loading from application: application_helper
>
>
> Processing ApplicationController#index (for 127.0.0.1 at 2007-09-28
> 10:35:23) [GET]
>   Session ID: 06f8d68d3bcfb730b0ca982fecfdfe6c
>   Parameters: {}
>
>
> ActionController::RoutingError (no route found to match
> "/admin/categories/list" with {:method=>:get}):
> _______________________________________________
> Engine-Users mailing list
> [EMAIL PROTECTED]
> http://lists.rails-engines.org/listinfo.cgi/engine-users-rails-engines.org
>


-- 
* J *
  ~
_______________________________________________
Engine-Users mailing list
[EMAIL PROTECTED]
http://lists.rails-engines.org/listinfo.cgi/engine-users-rails-engines.org