Loading...

freebsd-gnome@freebsd.org

[Prev] Thread [Next]  |  [Prev] Date [Next]

pulseaudio upgrade (after xcb-util) Barbara Wed Feb 01 20:02:44 2012

As I've reported a couple of time in previous occasions, the upgrade of 
pulseaudio caused some troubles because of some ports not being bumped.
In particular, I have those tree ports:
audo/libcanberra (ok, PULSE is NOT checked by default, I have it checked)
sysutils/gnome-settings-daemon (PULSEAUDIO is checked by default)
audio/gnome-media
This is the output (part of) of libchk 
Unresolvable link(s) found in: /usr/local/bin/gnome-volume-control
        libpulsecommon-0.9.22.so
Unresolvable link(s) found in: /usr/local/bin/gnome-volume-control-applet
        libpulsecommon-0.9.22.so
Unresolvable link(s) found in: /usr/local/lib/pulse-0.9.22/modules/module-
mmkbd-evdev.so
        libpulsecommon-0.9.22.so
        libpulsecore-0.9.22.so
Unresolvable link(s) found in: /usr/local/lib/libcanberra-0.28/libcanberra-
pulse.so
        libpulsecommon-0.9.22.so
Unresolvable link(s) found in: /usr/local/lib/gnome-settings-daemon-2.0
/libmedia-keys.so
        libpulsecommon-0.9.22.so

After upgrading all the ports and noticing that fact, I changed my mind and 
decided to rebuild libcanberra WITHOUT_PULSE and then to rebuild the other two.
I don't know why it didn't happened on the first build, but for sysutils/gnome-
settings-daemon now I'm getting an error caused by the removal of 
/usr/local/lib/libxcb-aux.la from xcb-util (and I don't know in which port it 
should be now):

/bin/sh ../../libtool --tag=CC   --mode=link cc -D_THREAD_SAFE -D_REENTRANT -
DORBIT2=1 -I/usr/local/include/gtk-2.0 -I/usr/local/lib/gtk-2.0/include -
I/usr/local/include/atk-1.0 -I/usr/local/include/cairo -I/usr/local/include/gdk-
pixbuf-2.0 -I/usr/local/include/pango-1.0 -I/usr/local/include/gio-unix-2.0/ -
I/usr/local/include -I/usr/local/include/glib-2.0 -I/usr/local/include/pixman-1 
-I/usr/local/include/freetype2 -I/usr/local/include/libpng -
I/usr/local/include/drm -I/usr/local/include/gconf/2 -I/usr/local/include/orbit-
2.0 -I/usr/local/include/gnome-desktop-2.0 -I/usr/local/include/startup-
notification-1.0 -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0
/include    -O2 -pipe -fno-strict-aliasing -march=prescott -export_dynamic -
module -avoid-version -no-undefined -L/usr/local/lib -R/usr/local/lib  -lSM -
lICE -lXext -lX11  -L/usr/local/lib -o libcommon.la  libcommon_la-
eggaccelerators.lo libcommon_la-gsd-keygrab.lo libcommon_la-gsd-osd-window.lo -
pthread -L/usr/local/lib -lgconf-2 -lgnome-desktop-2 -lgtk-x11-2.0 -lstartup-
notification-1 -lgdk-x11-2.0 -latk-1.0 -lpangocairo-1.0 -lXext -lXrender -
lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lgdk_pixbuf-2.0 -
lpangoft2-1.0 -lXfixes -lcairo -lX11 -lpango-1.0 -lm -lfreetype -lfontconfig -
lgio-2.0 -lgmodule-2.0 -ldbus-glib-1 -ldbus-1 -lgobject-2.0 -lgthread-2.0 -
lglib-2.0   
grep: /usr/local/lib/libxcb-aux.la: No such file or directory
/usr/local/bin/gsed: can't read /usr/local/lib/libxcb-aux.la: No such file or 
directory
libtool: link: `/usr/local/lib/libxcb-aux.la' is not a valid libtool archive
gmake[3]: *** [libcommon.la] Error 1
gmake[3]: Leaving directory `/usr/ports/sysutils/gnome-settings-
daemon/work/gnome-settings-daemon-2.32.1/plugins/common'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/sysutils/gnome-settings-
daemon/work/gnome-settings-daemon-2.32.1/plugins'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/sysutils/gnome-settings-
daemon/work/gnome-settings-daemon-2.32.1'
gmake: *** [all] Error 2
*** Error code 1

Barbara

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-gnome
To unsubscribe, send any mail to "[EMAIL PROTECTED]"