Loading...

jmeter-dev@jakarta.apache.org

[Prev] Thread [Next]  |  [Prev] Date [Next]

Re: XPathExtractor failing: HTTP 503 with DTD, a bug? sebb Fri Dec 18 08:00:40 2009

On 18/12/2009, Andrey Pohilko <[EMAIL PROTECTED]> wrote:
> Hello!
>
>
>
>  I'm testing XHTML pages and trying to extract data with XPathExtractor,
>  which works only when I use "Tidy" checkbox, fails otherwise. JMeter logs
>  and sniffer says that jmeter tries to load a DTD from www.w3.org, which
>  always responds with 503. I thought that "Use namespaces" will affect that
>  behavior, but it is not.
>
>
>
>  I suppose this is a bug, I tried several combinations of checkboxes and
>  found that JMeter completely unable to extract data from my XHTML without
>  Tidy. I wrote a unit test demonstrating the problem, 2 test files here:
>  <http://code.google.com/p/jmeter-plugins/source/browse/#svn/trunk/test/kg/ap
>  c/jmeter/xpathextractor>
>  http://code.google.com/p/jmeter-plugins/source/browse/#svn/trunk/test/kg/apc
>  /jmeter/xpathextractor
>
>
>
>  I use fake w3.org website on test host to workaround problem, but this is
>  not acceptable as solution I think J
>
>
>
>  Any comments?
>

This has been raised as a bug:

https://issues.apache.org/bugzilla/show_bug.cgi?id=47338

It's fixed in the current source, but has yet to be released.

It will be in nightly builds after 789187, if you want to try one of
those - but beware that such builds have not been thoroughly tested
and may misbehave badly.

>
>  Thanks,
>
>
>  Andrey
>
>
>
>
>  PS: sorry if I used wrong mailing list.
>
>
>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]