Loading...

jquery-dev@googlegroups.com

[Prev] Thread [Next]  |  [Prev] Date [Next]

[jquery-dev] Re: Compatibility Issues Karl Swedberg Wed May 20 14:00:35 2009

There were a number of changes between 1.1.4 and 1.2.x. Your best bet  
is to check the Release Notes, particularly these:
http://docs.jquery.com/Release:jQuery_1.2#Removed_Functionality

A few things to look for :
- XPath selectors.  Most of these were removed in 1.2. The XPath  
attribute selector was deprecated. Change them all to their CSS  
selector counterparts.
- .lt - removed. Use .slice() instead.
- .gt - removed. Use .slice() instead.
- A few of the ajax convenience methods. Check http://docs.jquery.com/Ajax 
  to see what's available now.

Hope that helps

--Karl

____________
Karl Swedberg
www.englishrules.com
www.learningjquery.com




On May 20, 2009, at 9:54 AM, Ken wrote:

>
> I have a client using 1.1.4.js and we are using 1.2.6.min.js. If the
> client upgrades, will it break their 1.1.4.js code? Is there any way
> to tell?
>
> Thank you in advance,
> Ken
>
> >


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"jQuery Development" group.
To post to this group, send email to [EMAIL PROTECTED]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/jquery-dev?hl=en
-~----------~----~----~----~------~----~------~--~---