Loading...

ledger-smb-users@lists.sourceforge.net

[Prev] Thread [Next]  |  [Prev] Date [Next]

Re: [Ledger-smb-users] attempted upgrade from ledgersmb 1.2 Chris Travers Mon Feb 13 20:00:48 2012

On Mon, Feb 13, 2012 at 7:09 PM, Michael Richardson <[EMAIL PROTECTED]>wrote:

>
> >>>>> "Chris" == Chris Travers <[EMAIL PROTECTED]> writes:
>     >> One note here, 9.1 wouldn't the reason.  The key questions here
>    >> are:
>    >>
>    >> 1) What's up with your data?  Did somehow something get changed
>    >> between 1.2 and 1.3?  Since the upgrade is non-destructive, we
>    >> can rule this out rather than simply asserting it's unlikely.
>    >>
>    >> 2) Once we rule out (or possibly confirm) a change going from 1.2
>    >> to 1.3, then we have to figure out why you are seeing these
>    >> problems in your installation.
>    >>
>    >> Note 1.3.11 has some new features which allow switching
>    >> debit/credit columns when trying to view something likea bank
>    >> statement.  However, these are not at issue in your installation
>    >> because I only coded them a couple weeks ago.
>    >>
>    >>
>     Chris> I haven't been able to reproduce the problem in 1.3.11-rc1.
>    Chris> The running balance shows the normal balance, not what you
>    Chris> are seeing.
>
>    Chris> If I am misunderstanding you and the problem is not just the
>    Chris> running balance column, please let me know.
>
> The sign of each transaction is reversed between 1.2 and 1.3.
>
> So, in 1.2, I put 18K into my checking account, and it increases by 18K.
> (note that in 1.2, those show under the debit column for reasons I never
> understood)
>
> After the upgrade, those transactions decrease my account by 18K.
>
> Maybe all my data is really actually wrong, and some bug in 1.2 made it
> all just work out.  (Like somehow, the accounts were marked contra, but
> really that's a 1.3 feature).
>

That's the running total.  It's showing debits as negative across the
board, and credits as positive.

Credits and debits are showing correctly.  The subtotal is not showing what
you expect it to show.    It's showing the absolute rather than normal
balance.

Look at the two screen shots.  All credit and debit entries are the same.
 The only column that is not is your running total.

I believe sometime between 1.3.9 and 1.3.11 this was changed but I am still
having difficulties finding the specific commit even though I have
identified the code.

Best Wishes,
Chris Travers
------------------------------------------------------------------------------
Keep Your Developer Skills Current with LearnDevNow!
The most comprehensive online learning library for Microsoft developers
is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
Metro Style Apps, more. Free future releases when you subscribe now!
http://p.sf.net/sfu/learndevnow-d2d
_______________________________________________
Ledger-smb-users mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/ledger-smb-users