Loading...

ledger-smb-users@lists.sourceforge.net

[Prev] Thread [Next]  |  [Prev] Date [Next]

[Ledger-smb-users] Installing 1.3 on Redhat or Fedora systems? Hilton Day Tue Feb 21 03:00:33 2012

Hi,

I've been running Ledger SMB since about 2007 - currently on 1.2.21, for a
small consulting practice (me).  I've recently been investigating migrating
to 1.3 (.10 and today .11) - but have run into a few difficulties, so have
some questions.

My plan is firstly to get a clean installation of 1.3 up and running, to
prove to myself that I'm satisfying all module dependencies etc. and to
have a look at 1.3.  Then once thats achieved, I'll work on the migration
of my existing 1.2 installation (or rather, on a virtualised clone of that
machine - so I don't need to roll-back if it has issues).

So anyway - my questions:

1.  Which RPM-based distribution is the RPM for?  Ideally, a version and
the distribution name - I've had little joy with Redhat Enterprise 5 or 6,
even using external repo's like "epel" and "atrpms" for the perl module
dependencies.  I'm currently installing Fedora 15 into a virtual machine to
try there.  There are invariably at least a couple of version
incompatibilities between dependencies to install the rpm.  I see in the
header of the rpm spec file it says tested on Centos 4 and 5, but I tried
to install the 1.3.10 rpm on Centos 5 and couldn't resolve the dependencies
using the defaults repos, or with the usual slew of external repo's
(epel/atrpms/rpmforge).

2.  In the INSTALL documentation file, it has under the Contents section:

 * Installing Perl module dependencies
   * for Fedora

But there's no list of rpm packages to be installed by yum to provide the
perl modules?  I see yum commands for installing the web server, postgres
etc. but it appears a section has perhaps been dropped in an earlier
revision?  Is there such a list of rpm dependencies somewhere? (I'll go dig
through earlier versions of the file to see - its been a few years since I
installed 1.2 so its all a bit hazy, but I do recall such a list of perl
dependencies existed)

3.  Is there an installation guide other than the INSTALL file?  My memory
is that for 1.2 there was an excellent section in the pdf-based Ledger-SMB
manual on installation, but its no longer there for 1.3?

If anyone can answer the above that would be great - even if the answer is
that the info doesn't exist.

Cheers,

Hilton.
Sydney - Australia
------------------------------------------------------------------------------
Keep Your Developer Skills Current with LearnDevNow!
The most comprehensive online learning library for Microsoft developers
is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
Metro Style Apps, more. Free future releases when you subscribe now!
http://p.sf.net/sfu/learndevnow-d2d
_______________________________________________
Ledger-smb-users mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/ledger-smb-users