Loading...

lfs-support@linuxfromscratch.org

[Prev] Thread [Next]  |  [Prev] Date [Next]

Re: [blfs-support] Libassuan 2.0.2 and pth Michael Shell Fri Feb 17 06:00:41 2012

On Fri, 17 Feb 2012 00:20:14 +0200
Thanos Baloukas <[EMAIL PROTECTED]> wrote:

> libassuan-2.0.0 $ ./configure --prefix=/usr LIBS=`pth-config --libs`

Yeah, that gets it in there alright. However, I guess the question at
hand now is does gpg2 still require libassuan to be linked to libpth?
My build of gnupg-2.0.18 didn't seem to mind that it wasn't.

Looking at gnupg-2.0.18's ChangeLog and NEWS, I see:

: 2010-02-11  Marcus Brinkmann  <[EMAIL PROTECTED]>
: From trunk 2009-10-16:
: * configure.ac: Check for libassuan instead of libassuan-pth.

and

: Noteworthy changes in version 2.0.15 (2010-03-09)
: * Make use of libassuan 2.0 which is available as a DSO.

So, it seems that we do not need to link libassuan against pth anymore
nor do we need any libassuan static libs. So, the default libassuan
configure settings do just fine for gpg2 as-is. 

On a related note about the BLFS libassuan page:

http://www.linuxfromscratch.org/blfs/view/cvs/general/libassuan.html

: Other packages (such as GnuPG-2) will require that the Libassuan
: library is linked to the Pth library. Ensure Pth is installed before
: beginning the build if you have any doubts. 

Does anyone know what other packages (besides gpg2) want(ed) pth in
libassuan?


  Cheers,

  Mike


-- 
http://linuxfromscratch.org/mailman/listinfo/blfs-support
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page