Loading...

linux-cluster@redhat.com

[Prev] Thread [Next]  |  [Prev] Date [Next]

[Linux-cluster] Problems with an apache resource with RHCS under CentOS 6.2 C. L. Martinez Mon Feb 27 03:00:40 2012

Hi all,

 I am trying to setup an apache resource under my rhcs. My
cluster.conf configuration is:

<service autostart="0" domain="SecondCluster" exclusive="0"
name="elsawww-svc" recovery="relocate">
       <fs ref="elsawebdata">
               <ip ref="192.168.44.7">
                      <apache ref="httpd-cluster"/>
               </ip>
        </fs>
</service>

 This config works ok when I use CentOS 5.7 and RHCS 2.x as a hosts,
but with RHCS 3.x, don't. rg_test output is:

[EMAIL PROTECTED] httpd]# rg_test test /etc/cluster/cluster.conf
start service elsawww-svc
Running in test mode.
Loading resource rule from /usr/share/cluster/script.sh
Loading resource rule from /usr/share/cluster/vm.sh
Loading resource rule from /usr/share/cluster/fs.sh
Loading resource rule from /usr/share/cluster/service.sh
Loading resource rule from /usr/share/cluster/oracledb.sh
Loading resource rule from /usr/share/cluster/lvm_by_lv.sh
Loading resource rule from /usr/share/cluster/fence_scsi_check.pl
Loading resource rule from /usr/share/cluster/openldap.sh
Loading resource rule from /usr/share/cluster/SAPDatabase
Loading resource rule from /usr/share/cluster/ocf-shellfuncs
Loading resource rule from /usr/share/cluster/netfs.sh
Loading resource rule from /usr/share/cluster/ip.sh
Loading resource rule from /usr/share/cluster/nfsclient.sh
Loading resource rule from /usr/share/cluster/clusterfs.sh
Loading resource rule from /usr/share/cluster/orainstance.sh
Loading resource rule from /usr/share/cluster/ASEHAagent.sh
Loading resource rule from /usr/share/cluster/nfsserver.sh
Loading resource rule from /usr/share/cluster/nfsexport.sh
Loading resource rule from /usr/share/cluster/oralistener.sh
Loading resource rule from /usr/share/cluster/apache.sh
Loading resource rule from /usr/share/cluster/postgres-8.sh
Loading resource rule from /usr/share/cluster/samba.sh
Loading resource rule from /usr/share/cluster/mysql.sh
Loading resource rule from /usr/share/cluster/checkquorum
Loading resource rule from /usr/share/cluster/SAPInstance
Loading resource rule from /usr/share/cluster/svclib_nfslock
Loading resource rule from /usr/share/cluster/tomcat-6.sh
Loading resource rule from /usr/share/cluster/lvm.sh
Loading resource rule from /usr/share/cluster/named.sh
Loading resource rule from /usr/share/cluster/lvm_by_vg.sh
Starting elsawww-svc...
<info>   mounting /dev/dm-7 on /data/www
<err>    mount -t ext4  /dev/dm-7 /data/www
[fs] mount -t ext4  /dev/dm-7 /data/www
<debug>  Link for eth0: Detected
<info>   Adding IPv4 address 192.168.44.7/24 to eth0
<debug>  Pinging addr 192.168.44.7 from dev eth0
<debug>  Sending gratuitous ARP: 192.168.44.7 00:50:56:11:2a:aa brd
ff:ff:ff:ff:ff:ff
<debug>  Verifying Configuration Of apache:httpd-cluster
<debug>  Checking Syntax Of The File /data/config/etc/httpd/conf/httpd.conf
<debug>  Checking Syntax Of The File
/data/config/etc/httpd/conf/httpd.conf > Succeed
<debug>  Monitoring Service apache:httpd-cluster
<error>  Checking Existence Of File
/var/run/cluster/apache/apache:httpd-cluster.pid
[apache:httpd-cluster] > Failed
[apache] Checking Existence Of File
/var/run/cluster/apache/apache:httpd-cluster.pid
[apache:httpd-cluster] > Failed
<error>  Monitoring Service apache:httpd-cluster > Service Is Not Running
[apache] Monitoring Service apache:httpd-cluster > Service Is Not Running
<info>   Starting Service apache:httpd-cluster
<debug>  Looking For IP Addresses
<debug>  0 IP addresses found for elsawww-svc/httpd-cluster
<error>  Looking For IP Addresses [apache:httpd-cluster] > Failed - No
IP Addresses Found
[apache] Looking For IP Addresses [apache:httpd-cluster] > Failed - No
IP Addresses Found
Failed to start elsawww-svc

As you can see, I am assigning 192.168.44.7 ip to this resource ...
Why doesn't works??

Thanks.

--
Linux-cluster mailing list
[EMAIL PROTECTED]
https://www.redhat.com/mailman/listinfo/linux-cluster