Loading...

modwsgi@googlegroups.com

[Prev] Thread [Next]  |  [Prev] Date [Next]

Re: [modwsgi] Invalid command 'WSGIScriptAlias' Graham Dumpleton Wed Dec 29 14:00:38 2010

On 30 December 2010 07:48, neridaj <[EMAIL PROTECTED]> wrote:
> I installed mod_wsgi via macports and believe that I have more than
> one version of apache2 as a result. I'm getting this error and it
> seems like I'm not running the mod_wsgi apache2 dependency as the
> version of apache2 that is currently running can't find the installed
> module.
>
> 12/28/10 5:35:16 PM     org.apache.httpd[1087]  Syntax error on line 63 of /
> private/etc/apache2/extra/httpd-vhosts.conf:
> 12/28/10 5:35:16 PM     org.apache.httpd[1087]  Invalid command
> 'WSGIScriptAlias', perhaps misspelled or defined by a module not
> included in the server configuration
>
> If I do in fact need to switch apache2 from /private/etc/apache2 to /
> opt/local/apache2 can anyone tell me how to do this?

The other possibility is that you haven't added the 'LoadModule' line
to get Apache to load mod_wsgi in the first place.

Try some of the checks in:

  http://code.google.com/p/modwsgi/wiki/CheckingYourInstallation

But yes you are likely right, using MacPorts likely means you have two
Apache installations or mod_wsgi was installed in wrong spot.

Personally I would suggest not using MacPorts, it is usually a PITA,
although not so bad these days as it used to be.

Graham

> Thanks,
>
> Jason
>
> --
> You received this message because you are subscribed to the Google Groups 
> "modwsgi" group.
> To post to this group, send email to [EMAIL PROTECTED]
> To unsubscribe from this group, send email to [EMAIL PROTECTED]
> For more options, visit this group at 
> http://groups.google.com/group/modwsgi?hl=en.
>
>

-- 
You received this message because you are subscribed to the Google Groups 
"modwsgi" group.
To post to this group, send email to [EMAIL PROTECTED]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/modwsgi?hl=en.