Loading...

nunit-discuss@googlegroups.com

[Prev] Thread [Next]  |  [Prev] Date [Next]

[nunit-discuss] Re: Different results in nunit gui and console Sean W. Thu Apr 05 12:01:34 2012

Different situation.

As stated above. The GUI passes all. The Console has errors in 2.6.

On Apr 5, 2:41 pm, Charlie Poole <[EMAIL PROTECTED]> wrote:
> A bug has been reported in the Gui by which failing tests are not
> propagated to the higher level suite. The failed test is marked as
> failed in the tree, but it's parent suites don't show the failure.
> Could you check to see if that's your situation or if the test is
> actually shown as passing?
>
> For a failed test, you should see the failure in the Errors and
> Failures tab and it should also be indicated on the test properties
> display, accessible through the context menu. Please check both
> places.
>
> This way we can figure out if it's a known bug or something new.
>
> Charlie
>
>
>
>
>
>
>
> On Thu, Apr 5, 2012 at 3:22 AM, Sean W. <[EMAIL PROTECTED]> wrote:
> > I too am having a similar issue after trying to upgrade to 2.6.
> > We currently use 2.5.3.9345 and all tests pass. Upgraded to
> > 2.6.0.12051 and all tests pass in the GUI, not some tests fail in the
> > console.
>
> > I can try to debug some of the failing tests today and reply later.
>
> > Is something wrong with the new release?
>
> > On Feb 6, 7:25 pm, Charlie Poole <[EMAIL PROTECTED]> wrote:
> >> Hi Mike,
>
> >> The general, not-very-helpful answer is that the two runners 
> >> containdifferentcode. :-) The execution code will be unified in 
> >> thenunitengine
> >> underNUnit3.0. Of course, that only means they will both do the
> >> same thing - they could still both fail.
>
> >> I suggest you start by debugging into your test and figuring out exactly
> >> what it is that's unexpectedly null and where it comes from.NUnitcould
> >> still be the culprit, but we have to start where the error is found.
>
> >> Charlie
>
> >> On Sat, Feb 4, 2012 at 7:55 PM, mikedrmfs <[EMAIL PROTECTED]> wrote:
> >> > Thenunit-consoleruns without an error butnunit.exe (gui) gives this
> >> > error
>
> >> > OdeToFood.Tests.HomeControllerIndexTest.Puts_Message_In_ViewBag:
> >> > System.NullReferenceException : Object reference not set to an
> >> > instance of an object.
>
> >> > at OdeToFood.Controllers.HomeController.Index() in C:\websites
> >> > \OdeToFood\OdeToFood\Controllers\HomeController.cs:line 15
> >> > at OdeToFood.Tests.HomeControllerIndexTest.Puts_Message_In_ViewBag()
> >> > in C:\websites\OdeToFood\OdeToFood.Tests\HomeControllerTest.cs:line 17
>
> >> > Why does theguiget an error and theconsolerun clean?
> >> > Thanks
>
> >> > --
> >> > You received this message because you are subscribed to the Google 
> >> > Groups "NUnit-Discuss" group.
> >> > To post to this group, send email [EMAIL PROTECTED]
> >> > To unsubscribe from this group, send email [EMAIL PROTECTED]
> >> > For more options, visit this group 
> >> > athttp://groups.google.com/group/nunit-discuss?hl=en.
>
> > --
> > You received this message because you are subscribed to the Google Groups 
> > "NUnit-Discuss" group.
> > To post to this group, send email to [EMAIL PROTECTED]
> > To unsubscribe from this group, send email to [EMAIL PROTECTED]
> > For more options, visit this group 
> > athttp://groups.google.com/group/nunit-discuss?hl=en.

-- 
You received this message because you are subscribed to the Google Groups 
"NUnit-Discuss" group.
To post to this group, send email to [EMAIL PROTECTED]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/nunit-discuss?hl=en.