Loading...

prototype-scriptaculous@googlegroups.com

[Prev] Thread [Next]  |  [Prev] Date [Next]

[Proto-Scripty] Re: Ajax.Updater output garbled only on iPhone first load Junkshops Mon Apr 02 12:00:10 2012

Hi guys, thanks for the responses.

Walter said:
> Look very carefully at the headers being sent by your server at the initial request and subsequent ones -- make sure everything is Unicode all the way through. (You don't need anything more exotic than Firebug to see that.) Garbled characters can mean that Unicode is being sent as if it was another charset. Maybe your initial load isn't explicitly setting the UTF-8 charset as the desired response, but since all subsequent responses are to Ajax loads (where the charset is explicitly requested) the text appears to "correct" itself.

I checked the headers from the Ajax.Updater calls on the initial load and on reloads and they're identical (other than the date and timeout max numbers). The charset request in the post is: Accept-Charset ISO-8859-1,utf-8;q=0.7,*;q=0.7

I should also make it clear that all the loads I'm talking about are Ajax loads - the initial as well as all subsequent ones.

Victor said:
>I would try to capture requests/responses in first and second time and compare if they are same (in other words, assure problem isn't somewhere on the server side).

The best I can do is check them out in Firebug and they're exactly as I'd expect. I don't see how the problem could be on the server side - in one of the loads all I'm doing is grabbing a static html file.

Thanks for the advice so far.

--
You received this message because you are subscribed to the Google Groups "Prototype 
& script.aculo.us" group.
To post to this group, send email to [EMAIL PROTECTED]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/prototype-scriptaculous?hl=en.