Loading...

puppet-users@googlegroups.com

[Prev] Thread [Next]  |  [Prev] Date [Next]

[Puppet Users] Multiple runs needed to update configs? Mike Knell Sat Feb 25 12:00:06 2012

Hey folks,

I've got a fairly basic out-of-the-box puppetmaster/puppet setup (out
of the box on Ubuntu, that is), but am running into a bit of an odd
problem with updating clients.

The first time a host runs Puppet, and every time I change anything in
the configs on the server, the agent has to run once and abort for
each included class (module, thing..) on the machine I'm trying to
configure before it finally just works after 'n' tries and everything
works fine.

I've tried to Google this, asked some colleagues with Puppet smarts,
and not come up with any useful hints. Anyone got any idea what's
going on here? See below for a sample run of (multiple) attempts.

Cheers,
Mike

# puppet agent --test
err: Could not retrieve catalog from remote server: Error 400 on
SERVER: Could not find class unix for hostname.uffish.net at
/etc/puppet/manifests/templates.pp:2 on node hostname.uffish.net
warning: Not using cache on failed catalog
err: Could not retrieve catalog; skipping run
# puppet agent --test
err: Could not retrieve catalog from remote server: Error 400 on
SERVER: Could not find class users for hostname.uffish.net at
/etc/puppet/manifests/templates.pp:3 on node hostname.uffish.net
warning: Not using cache on failed catalog
err: Could not retrieve catalog; skipping run
# puppet agent --test
err: Could not retrieve catalog from remote server: Error 400 on
SERVER: Could not find class ntp for hostname.uffish.net at
/etc/puppet/manifests/templates.pp:8 on node hostname.uffish.net
warning: Not using cache on failed catalog
err: Could not retrieve catalog; skipping run
# puppet agent --test
err: Could not retrieve catalog from remote server: Error 400 on
SERVER: Could not find class bind for hostname.uffish.net at
/etc/puppet/manifests/templates.pp:9 on node hostname.uffish.net
warning: Not using cache on failed catalog
err: Could not retrieve catalog; skipping run
# puppet agent --test
err: Could not retrieve catalog from remote server: Error 400 on
SERVER: Could not find class squid for hostname.uffish.net at
/etc/puppet/manifests/templates.pp:24 on node hostname.uffish.net
warning: Not using cache on failed catalog
err: Could not retrieve catalog; skipping run
# puppet agent --test
info: Caching catalog for hostname.uffish.net
(from here on in, runs normally)

-- 
You received this message because you are subscribed to the Google Groups 
"Puppet Users" group.
To post to this group, send email to [EMAIL PROTECTED]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/puppet-users?hl=en.