Loading...

railsfrance@googlegroups.com

[Prev] Thread [Next]  |  [Prev] Date [Next]

Re: [RailsFr] petit problème de déclaration de mé thode olivi morel Tue Nov 16 15:00:33 2010

oui mon user se trouve cree dans ma base

Le 16 novembre 2010 22:17, guillaume belleguic <
[EMAIL PROTECTED]> a écrit :

> Bonsoir,
>
> Le redirection_to '/' doit renvoyé vers une action index... Non ? Ton user
> est crée ds ta base ?
>
> Le 16 nov. 2010 à 21:43, olivi morel <[EMAIL PROTECTED]> a écrit :
>
> bonjour ou bonsoir
>
> je me trouve devant un petit problème je suis entrain d'essayer un
> formulaire pour enregistrer mon utilisateur
> mon problème se trouve être le suivant quand je clique sur ajouter j ai le
> droit au message suivant
> Unknown action
>
> No action responded to index. Actions: all, create, new, and show
>
>
> *voici le formulaire *: new.html
>     <% form_for @user do |f| %>
>         <%= f.error_messages %>
>         <div>
>             <%= f.label 'email' %>
>             <%= f.text_field :email %>
>         </div>
>
>         <div>
>             <%= f.label 'Mot de passe' %>
>             <%= f.password_field :password %>
>         </div>
>
>         <div>
>             <%= f.label 'Confirmation du mot de passe' %>
>             <%= f.password_field :password_confirmation %>
>
>             <p>il y a nb personne </p>
>             <%= User.all.count() %>
>             </div>
>
>                 <div>
>             <%= f.submit "Ajouter"%>
>
>             <% end %>
> *
> voici le controller* : users_controller.rb
>
>     def new
>         @user = User.new
>       end
>
>       def create
>         @user = User.new(params[:user])
>         if @user.save
>           flash[:notice] = "Votre compte a bien été créé"
>
>           redirect_to '/'
>
>       else
>          flash[:notice] = "probléme pour créé le compte"
>           render :action => :new
>         end
>       end
>
> il me reste une dernière question <330.png> pourquoi ci je crée un fichier
> du nom de ma methode, create.html dans */view/users* et que je colle
> l'ensemble de mon formulaire cela fonctionne ??
>
> je tiens avant tout à vous remercier pour votre aide à tous .
>
>
>  --
> Vous avez reçu ce message, car vous êtes abonné au groupe "Railsfrance" de
> Google Groups.
> Pour transmettre des messages à ce groupe, envoyez un e-mail à l'adresse
> <[EMAIL PROTECTED]>[EMAIL PROTECTED]
> Pour résilier votre abonnement envoyez un e-mail à l'adresse
> <[EMAIL PROTECTED]>
> [EMAIL PROTECTED]
>
>  --
> Vous avez reçu ce message, car vous êtes abonné au groupe "Railsfrance" de
> Google Groups.
> Pour transmettre des messages à ce groupe, envoyez un e-mail à l'adresse
> [EMAIL PROTECTED]
> Pour résilier votre abonnement envoyez un e-mail à l'adresse
> [EMAIL PROTECTED]

-- 
Vous avez reçu ce message, car vous êtes abonné au groupe "Railsfrance" de 
Google Groups.
Pour transmettre des messages à ce groupe, envoyez un e-mail à l'adresse [EMAIL 
PROTECTED]
Pour résilier votre abonnement envoyez un e-mail à l'adresse [EMAIL PROTECTED]