Loading...

rt-devel@lists.bestpractical.com

[Prev] Thread [Next]  |  [Prev] Date [Next]

Re: [Rt-devel] Issue with missing themes when moving to RT4 Kevin Falcone Tue Sep 13 20:01:10 2011

On Tue, Sep 13, 2011 at 11:44:05AM -0400, [EMAIL PROTECTED] wrote:
>    We are slowly moving from 3.8 to 4.0.2, and noticed a problem for our 
> staff who use themes
>    which do not exist in RT4.   After we converted the database to v4, they 
> could not login to RT
>    and would only see: "..could not find component for path 
> '/NoAuth/css/3.4-compat/main.css'
>    ..."
> 
>    I created symbolic links from /NoAuth/css/web2 to the missing themes 
> (3.4-compat and
>    3.5-default). Now our users can login and change to one of the supported 
> rt4 themes.   Not
>    ideal, but easy and effective.  Please let me know if this was the wrong 
> thing to do.
> 
>    Not clear if It is worth checking in Elements/Header to see if the user's 
> theme does not exist
>    and then try to fall back to the System Default.
> 
>    This issue might be worth a line in the docs/UPGRADING-4.0 file.

There's a ticket for this
http://issues.bestpractical.com/Ticket/Display.html?id=18271 (guest/guest)
and I believe a branch, but I can't find that right now.

-kevin
--------
RT Training Sessions (http://bestpractical.com/services/training.html)
*  Chicago, IL, USA — September 26 & 27, 2011
*  San Francisco, CA, USA — October 18 & 19, 2011
*  Washington DC, USA — October 31 & November 1, 2011
*  Melbourne VIC, Australia — November 28 & 29, 2011
*  Barcelona, Spain — November 28 & 29, 2011
List info: http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-devel