Loading...

thinking-sphinx@googlegroups.com

[Prev] Thread [Next]  |  [Prev] Date [Next]

[ts] NoMethodError: undefined method `constantize' for 0:Fixnum Arun Kumar Nachimuthu Fri Feb 03 11:11:59 2012

I face an issue only with my staging environment. This does not happen
in my dev mode.

When I try to use ThinkingSphinx.search(term), I get a traceback like
the

following:

[GEM_ROOT]/gems/thinking-sphinx-1.4.11/lib/thinking_sphinx/search.rb:
934:in `class_from_crc'
[GEM_ROOT]/gems/thinking-sphinx-1.4.11/lib/thinking_sphinx/search.rb:
913:in `instances_from_matches'
[GEM_ROOT]/gems/activesupport-2.3.11/lib/active_support/
ordered_hash.rb:115:in `each'
[GEM_ROOT]/gems/activesupport-2.3.11/lib/active_support/
ordered_hash.rb:115:in `each'
[GEM_ROOT]/gems/thinking-sphinx-1.4.11/lib/thinking_sphinx/search.rb:
911:in `instances_from_matches'
[GEM_ROOT]/gems/thinking-sphinx-1.4.11/lib/thinking_sphinx/search.rb:
434:in `compose_results'
[GEM_ROOT]/gems/thinking-sphinx-1.4.11/lib/thinking_sphinx/search.rb:
424:in `populate'
[GEM_ROOT]/gems/thinking-sphinx-1.4.11/lib/thinking_sphinx/search.rb:
562:in `call'
[GEM_ROOT]/gems/thinking-sphinx-1.4.11/lib/thinking_sphinx/search.rb:
562:in `retry_on_stale_index'
[GEM_ROOT]/gems/thinking-sphinx-1.4.11/lib/thinking_sphinx/search.rb:
404:in `populate'
[GEM_ROOT]/gems/thinking-sphinx-1.4.11/lib/thinking_sphinx/search.rb:
167:in `method_missing'


My environment:
  * rails (2.3.11)
  * riddle (1.5.1) as a gem
  * thinking-sphinx (1.4.11) as a gem
  * sphinx (2.0.3)

Here is my sphinx.yml

development:
    stopwords: <%= RAILS_ROOT%>/config/stopwords.txt
    mem_limit: 1024M
    min_word_len: 3
    max_matches: 30000
    max_filter_values: 300000

staging:
    config_file: ../../sphinx_index/staging/sphinx.conf
    searchd_file_path: ../../sphinx_index/staging/
    stopwords: <%= RAILS_ROOT%>/config/stopwords.txt
    mem_limit: 1024M
    max_matches: 30000
    max_filter_values: 300000
    bin_path: /usr/local/bin


I saw in github a similar problem which got fixed for TS 2.x
version(https://github.com/freelancing-god/thinking-sphinx/issues/
268). I would assume this was fixed for 1.4.11 version as well. What
might have caused this issue?

-- 
You received this message because you are subscribed to the Google Groups 
"Thinking Sphinx" group.
To post to this group, send email to [EMAIL PROTECTED]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/thinking-sphinx?hl=en.